***Unequal Load Balance With Hotspot***


/ip pool
add name=dhcp_pool1 ranges=192.168.21.2-192.168.21.254

/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=Local name=dhcp1

/ip address
add address=192.168.1.2/24 interface=WAN1
add address=192.168.2.2/24 interface=WAN2
add address=192.168.21.1/24 interface=Local

/ip dhcp-server network
add address=192.168.21.0/24 gateway=192.168.21.1

/ip dns
set allow-remote-requests=yes cache-size=5000KiB max-udp-packet-size=2048 servers=192.168.1.1,192.168.2.1

/ip firewall mangle
add action=mark-routing chain=output connection-mark=WAN5_conn new-routing-mark=to_WAN1
add action=mark-routing chain=output connection-mark=WAN6_conn new-routing-mark=to_WAN2
add chain=prerouting dst-address=192.168.1.0/24 in-interface=Local
add chain=prerouting dst-address=192.168.2.0/24 in-interface=Local
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=Local new-connection-mark=WAN1_conn per-connection-classifier=both-addresses-and-ports:3/0
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=Local new-connection-mark=WAN2_conn per-connection-classifier=both-addresses-and-ports:3/1
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=Local new-connection-mark=WAN1_conn per-connection-classifier=both-addresses-and-ports:3/2
add action=mark-routing chain=prerouting connection-mark=WAN1_conn in-interface=Local new-routing-mark=to_WAN1
add action=mark-routing chain=prerouting connection-mark=WAN2_conn in-interface=Local new-routing-mark=to_WAN2

/ip firewall nat
add action=masquerade chain=srcnat out-interface=WAN1
add action=masquerade chain=srcnat out-interface=WAN2
#add action=masquerade chain=srcnat comment="masquerade dhcp network" src-address=192.168.21.0/24 to-addresses=0.0.0.0

/ip route
add check-gateway=ping distance=1 gateway=192.168.1.1 routing-mark=to_WAN1
add check-gateway=ping distance=1 gateway=192.168.2.1 routing-mark=to_WAN2
add check-gateway=ping distance=1 gateway=192.168.1.1
add check-gateway=ping distance=2 gateway=192.168.2.1

after adding this script please go to ip -> hotspot and run hotspot setup.. Then reboot your MT and check.

Comments

Popular posts from this blog

DMASOFTLAB RADIUS MANAGER BILLING SYSTEM v 4.1 Finally Released

How To Configure Nano Station M2 As Access point